Hello,

Somebody posted a comment but couldn’t go through, had the error: Exception: Expected block 6 to be level 1, not 0

I see that the comments got in with git fine, but somehow it does not build properly. I also added a new post myself and got the same error when pushing.

 Exception: Expected block 6 to be level 1, not 0

I don’t really have much more details than that.

-- Hugo

Caused by ongoing problems with the xapian search engine corrupting its database, so when I saw an email from our cron job that detects these problems earlier this morning, I went in and fixed it.
Comment by joeyh.name Sun Nov 17 17:59:29 2013

Due to ongoing problems with xapian databases, I've changed all sites at branchable that have the search plugin enabled to use google for site-wide searches, insead of xapian.

If anyone wants to use xapain, you can turn the google_search option off in your site's config to get back to the old behavior. Or, help fix this vexing bug in xapian, or get ikiwiki supporting a better search engine.

Comment by joeyh.name Mon Nov 18 20:52:50 2013
Hi joey. Thanks for fixing this. Is there a way for users to customise the search path to rely on other search engines? (I’d probably go for duckduckgo myself)
Comment by Hugo Tue Nov 19 09:40:38 2013