I want to move my website to branchable. I presently compile it from this source. I'm happy to change the style quite a bit; the main thing is just to convert the file structure.

This directory maps pretty closely to the web routes.

First, ikiwiki doesn't seem to like ! as a file name; what can I do about that?

[tlevine@wildebeest thomaslevine-branchable]$ g push
Counting objects: 5, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (2/2), done.
Writing objects: 100% (4/4), 380 bytes | 0 bytes/s, done.
Total 4 (delta 0), reused 0 (delta 0)
remote: From /home/b-thomaslevine/source
remote:    d215636..c31e347  master     -> origin/master
remote: skipping bad filename !/index.txt
To tl:/
   d215636..c31e347  master -> master

Second, foo/index.rst gets mapped to /foo/index/ rather than /foo/. /foo/ still redirects to /foo/index/, but it breaks relative links. What can I do about this?

Thanks

The second problem may be able to be dealt with by enabling the indexpages setting. Look for "use page/index.mdwn source files" on the Setup page.

The first problem is probably best handled using Apache RewriteEngine rules. See Is it possible to set up Apache aliases for my blog?

Comment by joeyh.name Sat Apr 12 23:53:15 2014

An Apache RewriteEngine rule sounds good for the second thing.

On the first thing, I haven't found that plugin on the setup page, even in advanced mode; the only thing I found was autoindex.

Comment by Thomas Sun Apr 13 12:35:43 2014

This looks promising. I don't see those options in the setup page, but maybe I can set them in the ikiwiki.setup file?

I also suppose I could just move the files (clean but confusing for me) or use inline (messy but less confusing).

Comment by Thomas Sun Apr 13 12:40:57 2014
Hmm, turns out we have modification of the indexpages setting disabled for branchable sites. Probably because a user could accidentially enable it and break their site. I've turned it on for your site.
Comment by joeyh.name Tue Apr 15 20:29:30 2014

Thanks

It looks like I broke my site; this returns 500. Any ideas?

Comment by Thomas Sat Apr 19 18:55:12 2014

It was not you, it was me when I went in to manually tweak the config on the 15th.

Fixed.

(BTW, you're going to want to rename your .md files to .mdwn)

Comment by joeyh.name Sat Apr 19 20:33:52 2014
Changing the extensions is only the smallest of changes that I'll need to make.
Comment by Thomas Thu May 1 20:25:36 2014